summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix b/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
index 9c5ed7c..c90fe3e 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
@@ -9,13 +9,25 @@ in
       # Instance map is not needed for federation senders
       send_federation = false;
       federation_sender_instances = lib.map (index: "federation_sender-${toString index}") federationSenders;
+      outbound_federation_restricted_to = lib.map (index: "federation_sender-${toString index}") federationSenders;
     };
 
     workers = lib.listToAttrs (lib.map (index: {
       name = "federation_sender-${toString index}";
       value = {
         worker_app = "synapse.app.generic_worker";
-        worker_listeners = [ ];
+        worker_listeners = [
+          {
+            type = "http";
+            path = "/run/matrix-synapse/pusher-${toString index}.sock";
+            resources = [
+              {
+                names = ["replication"];
+                compress = false;
+              }
+            ];
+          }
+        ];
       };
     }) federationSenders);
   };