summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix91
1 files changed, 91 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix b/host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix
new file mode 100644
index 0000000..c2c84ec
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/synapse/workers/federation-inbound.nix
@@ -0,0 +1,91 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
+
+let
+  cfg = config.services.matrix-synapse;
+  workers = lib.range 0 (cfg.federationReaders - 1);
+  routes = [
+    "~ /_matrix/federation/(v1|v2)/send/"
+  ];
+in
+{
+  config = lib.mkIf (cfg.federationInboundWorkers > 0) {
+    services.matrix-synapse = {
+      settings = {
+        instance_map = lib.listToAttrs (
+          lib.map (index: {
+            name = "federation_inbound-${toString index}";
+            value = {
+              path = "/run/matrix-synapse/federation_inbound-${toString index}.sock";
+            };
+          }) workers
+        );
+      };
+
+      workers = lib.listToAttrs (
+        lib.map (index: {
+          name = "federation_inbound-${toString index}";
+          value = {
+            worker_app = "synapse.app.generic_worker";
+            worker_listeners = [
+              {
+                type = "http";
+                path = "/run/matrix-synapse/federation_inbound-${toString index}.sock";
+                resources = [
+                  {
+                    names = [ "replication" ];
+                    compress = false;
+                  }
+                ];
+              }
+              {
+                type = "http";
+                path = "/run/matrix-synapse/federation_inbound-federation-${toString index}.sock";
+                mode = "666";
+                resources = [
+                  {
+                    names = [ "federation" ];
+                    compress = false;
+                  }
+                ];
+              }
+            ];
+            database = (
+              import ../db.nix {
+                workerName = "federation_inbound-${toString index}";
+                dbGroup = "medium";
+              }
+            );
+          };
+        }) workers
+      );
+    };
+
+    services.nginx.upstreams."federation_inbound" = {
+      extraConfig = ''
+        keepalive 32;
+      '';
+      servers = lib.listToAttrs (
+        lib.map (index: {
+          name = "unix:/run/matrix-synapse/federation_inbound-federation-${toString index}.sock";
+          value = {
+            max_fails = 0;
+          };
+        }) workers
+      );
+    };
+
+    services.nginx.virtualHosts."${cfg.nginxVirtualHostName}".locations = lib.listToAttrs (
+      lib.map (route: {
+        name = route;
+        value = {
+          proxyPass = "http://federation_inbound";
+        };
+      }) routes
+    );
+  };
+}