summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/appservice.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/appservice.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix b/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
new file mode 100644
index 0000000..906bec8
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, lib, ... }:
+
+let 
+  cfg = config.services.matrix-synapse;
+in
+{
+  services.matrix-synapse = lib.mkIf cfg.enableAppserviceWorker {
+    settings = {
+      instance_map = {
+        appservice = {
+          path = "/run/synapse/appservice.sock";
+        };
+      };
+
+      notify_appservices_from_worker = "appservice";
+    };
+
+    workers = {
+      appservice = {
+        worker_app = "synapse.app.generic_worker";
+        worker_listeners = [ ];
+      };
+    };
+  };
+}
\ No newline at end of file