summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/appservice.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/appservice.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix b/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
index d259edd..e3b07bc 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/appservice.nix
@@ -1,23 +1,20 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}:
+{ config, lib, ... }:
 
 let
   cfg = config.services.matrix-synapse;
+  workerName = "appservice";
+  workerRoutes = [ ];
 in
 {
   services.matrix-synapse = lib.mkIf cfg.enableAppserviceWorker {
     settings = {
       instance_map = {
         appservice = {
-          path = "/run/matrix-synapse/appservice.sock";
+          path = "/run/matrix-synapse/${workerName}.sock";
         };
       };
 
-      notify_appservices_from_worker = "appservice";
+      notify_appservices_from_worker = workerName;
     };
 
     workers = {
@@ -26,7 +23,7 @@ in
         worker_listeners = [
           {
             type = "http";
-            path = "/run/matrix-synapse/appservice.sock";
+            path = "/run/matrix-synapse/${workerName}.sock";
             resources = [
               {
                 names = [ "replication" ];