summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/ratelimits.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/ratelimits.nix59
1 files changed, 44 insertions, 15 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/ratelimits.nix b/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
index 4f6b7db..ffce1cc 100644
--- a/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
+++ b/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
@@ -1,22 +1,15 @@
 {
+  # messages
   rc_message = {
-    per_second = 1000;
-    burst_count = 1000;
+    per_second = 1000000;
+    burst_count = 1000000;
   };
-  rc_login = {
-    address = {
-      per_second = 1000;
-      burst_count = 1000;
-    };
-    account = {
-      per_second = 1000;
-      burst_count = 1000;
-    };
-    failed_attempts = {
-      per_second = 0.1;
-      burst_count = 3;
-    };
+  rc_admin_redaction = {
+    per_second = 10000000;
+    burst_count = 10000000;
   };
+
+  # room joins
   rc_joins = {
     local = {
       per_second = 1000;
@@ -31,6 +24,8 @@
     per_second = 1000;
     burst_count = 1000;
   };
+
+  # room invites
   rc_invites = {
     per_room = {
       per_second = 1000;
@@ -45,6 +40,12 @@
       burst_count = 1000;
     };
   };
+  rc_third_party_invite = {
+    per_second = 1000;
+    burst_count = 1000;
+  };
+
+  # federation
   rc_federation = {
     window_size = 10;
     sleep_limit = 1000;
@@ -53,4 +54,32 @@
     concurrent = 100;
   };
   federation_rr_transactions_per_room_per_second = 1;
+
+  # media
+  rc_media_create = {
+    per_second = 1000;
+    burst_count = 1000;
+  };
+  remote_media_download_burst_count = "512G";
+  remote_media_download_per_second = "512G";
+
+  # authentication
+  rc_login = {
+    address = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    account = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    failed_attempts = {
+      per_second = 0.1;
+      burst_count = 3;
+    };
+  };
+  rc_3pid_validation = {
+    per_second = 1000;
+    burst_count = 1000;
+  };
 }