summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/synapse.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse.nix b/host/Rory-nginx/services/matrix/synapse.nix
index df0b172..26c61a1 100755
--- a/host/Rory-nginx/services/matrix/synapse.nix
+++ b/host/Rory-nginx/services/matrix/synapse.nix
@@ -25,16 +25,16 @@
         max_long_retry_delay = "30s";
       };
 
-      event_cache_size = "30K"; #defaults to 10K
+      event_cache_size = "1200K"; #defaults to 10K
       caches = {
-        global_factor = 50.0;
-        cache_entry_ttl = "60m";
+        global_factor = 5000.0;
+        cache_entry_ttl = "12h";
         expire_caches = true;
-        sync_response_cache_duration = "5m";
+        sync_response_cache_duration = "6h";
         cache_autotuning = {
-          max_cache_memory_usage = "4096M";
-          target_cache_memory_usage = "1024M";
-          min_cache_ttl = "30m";
+          max_cache_memory_usage = "65536M";
+          target_cache_memory_usage = "32768M";
+          min_cache_ttl = "6h";
         };
       };