summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/draupnir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/draupnir.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/draupnir.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/host/Rory-nginx/services/matrix/draupnir.nix b/host/Rory-nginx/services/matrix/draupnir.nix
index e9fba15..f20a7d0 100755
--- a/host/Rory-nginx/services/matrix/draupnir.nix
+++ b/host/Rory-nginx/services/matrix/draupnir.nix
@@ -4,16 +4,17 @@
   services.draupnir = {
     enable = true;
     homeserverUrl = "https://matrix.rory.gay";
+    accessTokenFile = "/etc/draupnir-access-token";
 
-    pantalaimon = {
-      enable = true;
-      username = "draupnir";
-      passwordFile = "/etc/draupnir-password";
-      options = {
+    #pantalaimon = {
+    #  enable = false;
+    #  username = "draupnir";
+    #  passwordFile = "/etc/draupnir-password";
+    #  options = {
         #homeserver = "http://localhost:8008";
         #ssl = false;
-      };
-    };
+    #  };
+    #};
     settings = {
       managementRoom = "#draupnir-mgmt:rory.gay";
       verboseLogging = false;
@@ -21,7 +22,7 @@
       autojoinOnlyIfManager = true; # Let's not open ourselves up to DoS attacks
       automaticallyRedactForReasons = [ "*" ]; # I always want autoredact
       fasterMembershipChecks = true;
-      # roomStateBackingStore.enabled = true; # broken under nix.
+      roomStateBackingStore.enabled = true; # broken under nix.
 
       backgroundDelayMS = 10; # delay isn't needed, I don't mind the performance hit
       pollReports = false; # this is a single person homeserver... let's save ourself the work