summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/draupnir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/draupnir.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/draupnir.nix21
1 files changed, 4 insertions, 17 deletions
diff --git a/host/Rory-nginx/services/matrix/draupnir.nix b/host/Rory-nginx/services/matrix/draupnir.nix
index f2a8357..9f48e6d 100755
--- a/host/Rory-nginx/services/matrix/draupnir.nix
+++ b/host/Rory-nginx/services/matrix/draupnir.nix
@@ -1,22 +1,17 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}:
+{ ... }:
 
 {
-  # Alicia - doesnt work yet... until in nixpkgs...
   services.draupnir = {
     enable = true;
+    homeserverUrl = "https://matrix.rory.gay";
 
     pantalaimon = {
       enable = true;
       username = "draupnir";
       passwordFile = "/etc/draupnir-password";
       options = {
-        homeserver = "http://localhost:8008";
-        ssl = false;
+        #homeserver = "http://localhost:8008";
+        #ssl = false;
       };
     };
     settings = {
@@ -30,8 +25,6 @@
       backgroundDelayMS = 10; # delay isn't needed, I don't mind the performance hit
       pollReports = false; # this is a single person homeserver... let's save ourself the work
 
-      #homeserverUrl = "yes";
-
       admin.enableMakeRoomAdminCommand = true;
       commands.ban.defaultReasons = [
         "spam"
@@ -52,10 +45,4 @@
       };
     };
   };
-
-  #  services.pantalaimon-headless.instances.draupnir = {
-  #    homeserver = "http://localhost:8008";
-  #    ssl = false;
-  #  };
-
 }