summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/draupnir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/draupnir.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/draupnir.nix21
1 files changed, 14 insertions, 7 deletions
diff --git a/host/Rory-nginx/services/matrix/draupnir.nix b/host/Rory-nginx/services/matrix/draupnir.nix
index b5f5608..a527164 100755
--- a/host/Rory-nginx/services/matrix/draupnir.nix
+++ b/host/Rory-nginx/services/matrix/draupnir.nix
@@ -14,15 +14,17 @@
         ssl = false;
       };
     };
-    managementRoom = "#draupnir-mgmt:rory.gay";
-    homeserverUrl = "http://localhost:8008";
-    verboseLogging = false;
     settings = {
-      recordIgnoredInvites = false;
-      automaticallyRedactForReasons = [ "*" ];
+      managementRoom = "#draupnir-mgmt:rory.gay";
+      verboseLogging = false;
+      recordIgnoredInvites = true; # Let's log ignored invites, just incase
+      autojoinOnlyIfManager = true; # Let's not open ourselves up to DoS attacks
+      automaticallyRedactForReasons = [ "*" ]; # I always want autoredact
       fasterMembershipChecks = true;
-      backgroundDelayMS = 100;
-      pollReports = true;
+
+      backgroundDelayMS = 10; # delay isn't needed, I don't mind the performance hit
+      pollReports = false; # this is a single person homeserver... let's save ourself the work
+      
       admin.enableMakeRoomAdminCommand = true;
       commands.ban.defaultReasons = [
         "spam"
@@ -42,5 +44,10 @@
     };
   };
 
+#  services.pantalaimon-headless.instances.draupnir = {
+#    homeserver = "http://localhost:8008";
+#    ssl = false;
+#  };
+
 }