summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/draupnir-cme/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/draupnir-cme/root.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/draupnir-cme/root.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/containers/draupnir-cme/root.nix b/host/Rory-nginx/services/containers/draupnir-cme/root.nix
new file mode 100755
index 0000000..6725c3b
--- /dev/null
+++ b/host/Rory-nginx/services/containers/draupnir-cme/root.nix
@@ -0,0 +1,44 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
+
+{
+  imports = [
+    ./services/draupnir.nix
+  ];
+
+  environment.systemPackages = with pkgs; [
+    neofetch
+    lnav
+    zsh
+    lsd
+    htop
+    btop
+    duf
+    kitty.terminfo
+    neovim
+    jq
+    yq
+    pv
+    dig
+  ];
+
+  environment.etc."resolv.conf".text = ''
+    nameserver 8.8.8.8
+    nameserver 8.4.4.8
+    nameserver 1.1.1.1
+    nameserver 1.0.0.1
+  '';
+
+  environment.etc."hosts".text = ''
+    192.168.100.16 matrix.rory.gay
+    192.168.100.16 rory.gay
+  '';
+
+  networking.firewall = {
+    enable = true;
+  };
+}