summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix100
1 files changed, 0 insertions, 100 deletions
diff --git a/host/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix b/host/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix
deleted file mode 100755
index a33c784..0000000
--- a/host/Rory-nginx/services/containers/conduwuit-throwaway/services/nginx.nix
+++ /dev/null
@@ -1,100 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{
-  services = {
-    nginx = {
-      enable = true;
-      package = pkgs.nginxQuic;
-      recommendedProxySettings = true;
-      recommendedTlsSettings = true;
-      recommendedZstdSettings = true;
-      recommendedGzipSettings = true;
-      recommendedBrotliSettings = true;
-      recommendedOptimisation = true;
-      appendConfig = ''
-        worker_processes 16;
-        '';
-       eventsConfig = ''
-        #use kqueue;
-        worker_connections 512;
-        '';
-      appendHttpConfig = ''
-        #sendfile on;
-        disable_symlinks off;
-      '';
-      additionalModules = with pkgs.nginxModules; [
-        moreheaders
-      ];
-      virtualHosts = {
-        "conduit.matrixunittests.rory.gay" = {
-          locations."/" = {
-            proxyPass = "http://127.0.0.1:6167"; 
-            extraConfig = ''
-              if ($request_method = 'OPTIONS') {
-                more_set_headers 'Access-Control-Allow-Origin: *';
-                more_set_headers 'Access-Control-Allow-Methods: *';
-                #
-                # Custom headers and headers various browsers *should* be OK with but aren't
-                #
-                more_set_headers 'Access-Control-Allow-Headers: *';
-                #
-                # Tell client that this pre-flight info is valid for 20 days
-                #
-                more_set_headers 'Access-Control-Max-Age: 1728000';
-                more_set_headers 'Content-Type: text/plain; charset=utf-8';
-                more_set_headers 'Content-Length: 0';
-                return 204;
-              }
-            '';
-          };
-          locations."= /.well-known/matrix/server".extraConfig = ''
-            more_set_headers 'Content-Type application/json';
-            more_set_headers 'Access-Control-Allow-Origin *';
-            return 200 '${builtins.toJSON {
-              "m.server" = "conduit.matrixunittests.rory.gay:443";
-            }}';
-          ''; 
-          locations."= /.well-known/matrix/client".extraConfig = ''
-            more_set_headers 'Content-Type application/json';
-            more_set_headers 'Access-Control-Allow-Origin *';
-            return 200 '${builtins.toJSON {
-              "m.homeserver".base_url = "https://conduit.matrixunittests.rory.gay";
-            }
-            }';
-          ''; 
-          locations."= /.well-known/matrix/support".extraConfig = ''
-            more_set_headers 'Content-Type application/json';
-            more_set_headers 'Access-Control-Allow-Origin *';
-            return 200 '${builtins.toJSON {
-              admins = [
-                  {
-                    matrix_id = "@emma:rory.gay";
-                    role = "admin";
-                  }
-                  {
-                    matrix_id = "@alicia:rory.gay";
-                    role = "admin";
-                  }
-                  {
-                    matrix_id = "@root:rory.gay";
-                    role = "admin";
-                  }
-                  {
-                    matrix_id = "@rory:rory.gay";
-                    role = "admin";
-                  }
-                ];
-              }
-            }';
-          '';
-        };
-      };
-    };
-  };
-  systemd.services.nginx.serviceConfig = {
-    LimitNOFILE=5000000;
-  };
-  security.acme.acceptTerms = true;
-  security.acme.defaults.email = "root@rory.gay";
-
-}