summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/thearcanebrony.net/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/hosts/thearcanebrony.net/root.nix')
-rwxr-xr-xhost/Rory-nginx/hosts/thearcanebrony.net/root.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/Rory-nginx/hosts/thearcanebrony.net/root.nix b/host/Rory-nginx/hosts/thearcanebrony.net/root.nix
index 50b6bc4..cec51cf 100755
--- a/host/Rory-nginx/hosts/thearcanebrony.net/root.nix
+++ b/host/Rory-nginx/hosts/thearcanebrony.net/root.nix
@@ -9,5 +9,30 @@
     "/destroy" = {
       return = "301 https://gitlab.com/KinoshitaProductions/SecureDestroyer/-/raw/master/run";
     };
+      locations."= /.well-known/matrix/support".extraConfig = ''
+    add_header Content-Type application/json;
+    add_header Access-Control-Allow-Origin *;
+    return 200 '${builtins.toJSON {
+      admins = [
+        {
+          matrix_id = "@emma:rory.gay";
+          role = "admin";
+        }
+	      {
+          matrix_id = "@alicia:rory.gay";
+          role = "admin";
+        }
+	      {
+          matrix_id = "@root:rory.gay";
+          role = "admin";
+        }
+      	{
+          matrix_id = "@rory:rory.gay";
+          role = "admin";
+        }
+      ];
+    }
+    }';
+  ''; 
   };
 }
\ No newline at end of file