summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/rory.gay/mru.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/hosts/rory.gay/mru.nix')
-rwxr-xr-xhost/Rory-nginx/hosts/rory.gay/mru.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/host/Rory-nginx/hosts/rory.gay/mru.nix b/host/Rory-nginx/hosts/rory.gay/mru.nix
index e82c0f9..d309946 100755
--- a/host/Rory-nginx/hosts/rory.gay/mru.nix
+++ b/host/Rory-nginx/hosts/rory.gay/mru.nix
@@ -7,9 +7,13 @@
       index = "index.html";
       extraConfig = ''
         add_header 'Access-Control-Allow-Origin' '*';
-        add_header 'Access-Control-Allow-Methods' 'GET, OPTIONS';
-        add_header 'Access-Control-Allow-Headers' 'DNT,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type,Range';
-        add_header 'Access-Control-Expose-Headers' 'Content-Length,Content-Range';
+        add_header 'Access-Control-Allow-Methods' '*';
+        add_header 'Access-Control-Allow-Headers' '*';
+        add_header 'Access-Control-Expose-Headers' '*';
+        add_header 'Access-Control-Max-Age' 1728000;
+
+        # default to /index.html if file not found
+        try_files $uri $uri/ index.html;
       '';
     };
   };