summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/rory.gay/matrix-bak.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/hosts/rory.gay/matrix-bak.nix')
-rwxr-xr-xhost/Rory-nginx/hosts/rory.gay/matrix-bak.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/Rory-nginx/hosts/rory.gay/matrix-bak.nix b/host/Rory-nginx/hosts/rory.gay/matrix-bak.nix
new file mode 100755
index 0000000..26507fc
--- /dev/null
+++ b/host/Rory-nginx/hosts/rory.gay/matrix-bak.nix
@@ -0,0 +1,25 @@
+{
+  enableACME = true;
+  addSSL = true;
+  locations."/_matrix" = {
+    proxyPass = "http://192.168.1.5:8008"; 
+    extraConfig = ''
+      if ($request_method = 'OPTIONS') {
+        add_header 'Access-Control-Allow-Origin' '*';
+        add_header 'Access-Control-Allow-Methods' '*';
+        #
+        # Custom headers and headers various browsers *should* be OK with but aren't
+        #
+        add_header 'Access-Control-Allow-Headers' '*';
+        #
+        # Tell client that this pre-flight info is valid for 20 days
+        #
+        add_header 'Access-Control-Max-Age' 1728000;
+        add_header 'Content-Type' 'text/plain; charset=utf-8';
+        add_header 'Content-Length' 0;
+        return 204;
+      }
+    '';
+  };
+  locations."/_synapse/client".proxyPass = "http://192.168.1.5:8008";   
+}