summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/rory.boo/tunnel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/hosts/rory.boo/tunnel.nix')
-rw-r--r--host/Rory-nginx/hosts/rory.boo/tunnel.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/Rory-nginx/hosts/rory.boo/tunnel.nix b/host/Rory-nginx/hosts/rory.boo/tunnel.nix
index e69de29..db81075 100644
--- a/host/Rory-nginx/hosts/rory.boo/tunnel.nix
+++ b/host/Rory-nginx/hosts/rory.boo/tunnel.nix
@@ -0,0 +1,12 @@
+{
+  locations = {
+    "/" = {
+      proxyPass = "http://127.0.0.1:12345";
+      proxyWebsockets = true;
+      extraConfig =
+        "proxy_ssl_server_name on;" +
+        "proxy_pass_header Authorization;"
+        ;
+    };
+  };
+}
\ No newline at end of file