summary refs log tree commit diff
path: root/host/Rory-desktop/optional/hardware-specific/amd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/optional/hardware-specific/amd.nix')
-rw-r--r--host/Rory-desktop/optional/hardware-specific/amd.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/host/Rory-desktop/optional/hardware-specific/amd.nix b/host/Rory-desktop/optional/hardware-specific/amd.nix
index 45bea66..3ae47d2 100644
--- a/host/Rory-desktop/optional/hardware-specific/amd.nix
+++ b/host/Rory-desktop/optional/hardware-specific/amd.nix
@@ -1,10 +1,16 @@
-{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  nhekoSrc,
+  mtxclientSrc,
+  ...
+}:
 
 {
-  imports =
-    [ ];
+  imports = [ ];
 
-boot.initrd.kernelModules = [ "amdgpu" ];
+  boot.initrd.kernelModules = [ "amdgpu" ];
 
   services = {
     xserver = {
@@ -28,16 +34,11 @@ boot.initrd.kernelModules = [ "amdgpu" ];
         rocmPackages.clr.icd
         amdvlk
       ];
-      extraPackages32 = with pkgs; [
-        driversi686Linux.amdvlk
-      ];
+      extraPackages32 = with pkgs; [ driversi686Linux.amdvlk ];
     };
   };
 
-  systemd.tmpfiles.rules = [
-    "L+    /opt/rocm/hip   -    -    -     -    ${pkgs.rocmPackages.clr}"
-  ];
+  systemd.tmpfiles.rules = [ "L+    /opt/rocm/hip   -    -    -     -    ${pkgs.rocmPackages.clr}" ];
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }
-