summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix108
1 files changed, 32 insertions, 76 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index da3d8e3..9f8da16 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -3,25 +3,31 @@
 {
   imports =
     [
+      # base imports
       ../../modules/base-client.nix
       ../../modules/packages/vim.nix
 #      ../../modules/environments/home.nix
       ../../modules/software-templates/profilers.nix
       ./postgres.nix
-      ./mariadb.nix
       ./nginx.nix
+
+      # hardware-specific imports
+      ./optional/hardware-specific/amd.nix
+
+      ./printing.nix
+      ./ollama.nix
     ];
 
-    boot = {
-      kernelPackages = pkgs.linuxPackages_latest;
-      loader = {
-        grub = {
-          enable = true;
-          device = "nodev"; # nodev for EFI only
-          # EFI
-          efiSupport = true;
-          efiInstallAsRemovable = true;
-        };
+  boot = {
+    kernelPackages = pkgs.linuxPackages_latest;
+    loader = {
+      grub = {
+        enable = true;
+        device = "nodev"; # nodev for EFI only
+        # EFI
+        efiSupport = true;
+        efiInstallAsRemovable = true;
+      };
     };
     #readOnlyNixStore = false;
   };
@@ -65,14 +71,15 @@
     xserver = {
       enable = true;
       updateDbusEnvironment = true;
-      videoDrivers = ["nvidia"];
+      #videoDrivers = ["amdgpu"]; #"nvidia"
       #desktopManager.gnome.enable = true;
       libinput.enable = true;
       layout = "us";
       windowManager.i3.enable = true;
       windowManager.i3.extraSessionCommands = ''
         # output from arandr:
-        xrandr --output DP-0 --off --output DP-1 --off --output DP-2 --off --output DP-3 --off --output HDMI-0 --primary --mode 3840x2160 --pos 0x0 --rotate normal --output DP-4 --off --output DP-5 --mode 1920x1080 --pos 3840x1080 --rotate normal
+        #xrandr --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --output HDMI-2 --off --output DP-2 --off
+        xrandr --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --primary --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-2 --off --output DP-2 --off
         ${pkgs.polybarFull}/bin/polybar &
         ${pkgs.dunst}/bin/dunst &
         ${pkgs.feh}/bin/feh --no-fehbg --bg-fill ${../../modules/users/Rory/wallpaper.webp}
@@ -121,13 +128,13 @@
   users.users = {
     Rory = {
       isNormalUser = true;
-      extraGroups = [ "wheel" "lp" "scanner" ];
+      extraGroups = [ "wheel" ];
       packages = with pkgs; [
         #gimp-with-plugins
 
         #xterm
-        gnomeExtensions.vitals
-        gnomeExtensions.runcat
+        #gnomeExtensions.vitals
+        #gnomeExtensions.runcat
       ];
       initialPassword = "password";
     };
@@ -143,15 +150,15 @@
     youtube-music
 
     # - IDEs
-    jetbrains-toolbox
+    #jetbrains-toolbox
     jetbrains.rider
-    jetbrains.webstorm
-    jetbrains.clion
+    #jetbrains.webstorm
+    #jetbrains.clion
     github-copilot-intellij-agent
     
     
-    dbeaver
-    insomnia
+    dbeaver-bin
+    #insomnia
     vscode
 
     # - Utilities
@@ -169,10 +176,6 @@
     steam-run
     steam-acf
 
-    #printing/scanning
-    xsane
-    gnome.simple-scan
-
     # extra packages
     dmenu
 
@@ -184,7 +187,7 @@
     #yuzu-early-access
     wineWowPackages.unstableFull
     winetricks
-    fragments
+    #fragments
     peek
 
     unrar-wrapper
@@ -193,9 +196,10 @@
     (callPackage ../../modules/packages/nheko-git.nix { inherit nhekoSrc; inherit mtxclientSrc; voipSupport = false; })
     #(callPackage ../../modules/packages/mc/server/modpack/curseforge/techopolis-2/5.4.nix { })
 
-    vesktop
+    #vesktop
+    virt-viewer
 
-    (dwarf-fortress-packages.dwarf-fortress-full.override { enableStoneSense = true; enableFPS = true; theme = dwarf-fortress-packages.themes.spacefox; })
+    # (dwarf-fortress-packages.dwarf-fortress-full.override { enableStoneSense = true; enableFPS = true; theme = dwarf-fortress-packages.themes.spacefox; })
   ];
 
   programs.steam.enable = true;
@@ -271,51 +275,8 @@
   };
 
   hardware = {
-    opengl = {
-      enable = true;
-      driSupport = true;
-      driSupport32Bit = true;
-    };
-
-    nvidia = {
-      modesetting.enable = true;
-      powerManagement.enable = false;
-      powerManagement.finegrained = false;
-      open = true;
-      nvidiaSettings = true;
-      nvidiaPersistenced = true;
-      package = config.boot.kernelPackages.nvidiaPackages.stable;
-    };
-
-    sane.enable = true;
-    sane.extraBackends = [ pkgs.hplipWithPlugin pkgs.sane-airscan ];
     pulseaudio.enable = false;
   };
-  programs.system-config-printer.enable = true;
-  services = {
-    gvfs.enable = true;
-    saned.enable = true;
-    system-config-printer.enable = true;
-    ipp-usb.enable = true;
-    printing = {
-      enable = true;
-      browsing = true;
-      drivers = with pkgs; [ hplip ];
-    };
-    avahi = {
-      enable = true;
-      nssmdns = true;
-      reflector = true;
-      publish = {
-        workstation = true;
-        userServices = true;
-        hinfo = true;
-        enable = true;
-        domain = true;
-        addresses = true;
-      };
-    };
-  };
   programs.dconf.enable = true;
   environment.etc."resolv.conf".text = ''
     nameserver 8.8.8.8
@@ -324,20 +285,15 @@
     nameserver 1.0.0.1
     '';
 
-
     #networking.wireguard.interfaces = {
     #  wg-KP-Ran = {
 
       #};
    # };
 
-
-
   virtualisation.libvirtd.enable = true;
   programs.virt-manager.enable = true;
 
-
-  
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }