summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index c0cd5f1..7f885e8 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -208,9 +208,16 @@
       extraPortals = with pkgs; [
         #xdg-desktop-portal-gtk
         xdg-desktop-portal-xapp
-        #(callPackage ../../modules/packages/xdg-desktop-portal-gtk.nix { })
+        (callPackage ../../modules/packages/xdg-desktop-portal-gtk.nix { })
       ];
+      config = {
+        common = {
+          default = [ "gtk" ];
+        };
+      };
       xdgOpenUsePortal = true;
+      gtkUsePortal = true;
+
     };
     #sounds.enable = true;
     #mime.enable = true;
@@ -269,8 +276,9 @@
       modesetting.enable = true;
       powerManagement.enable = false;
       powerManagement.finegrained = false;
-      open = true;
+      open = false;
       nvidiaSettings = true;
+      nvidiaPersistenced = true;
       package = config.boot.kernelPackages.nvidiaPackages.stable;
     };