summary refs log tree commit diff
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
deleted file mode 100644
index d465d53..0000000
--- a/hardware-configuration.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-# Do not modify this file!  It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations.  Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
-  imports =
-    [ (modulesPath + "/profiles/qemu-guest.nix")
-    ];
-
-  boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-amd" ];
-  boot.extraModulePackages = [ ];
-
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/df27a146-a490-4d5e-aa4b-8f52de9cf955";
-      fsType = "ext4";
-    };
-
-  fileSystems."/nix/store" =
-    { device = "/nix/store";
-      fsType = "none";
-      options = [ "bind" ];
-    };
-
-  fileSystems."/data" =
-    { device = "/dev/disk/by-uuid/ca6e141a-05af-48de-a97b-b75cda10f864";
-      fsType = "ext4";
-    };
-
-  fileSystems."/mnt/postgres" =
-    { device = "/dev/disk/by-uuid/c947f43c-5c80-4e29-ac8c-89763ecc02ad";
-      fsType = "ext4";
-    };
-
-  fileSystems."/mnt/sde" =
-    { device = "/dev/disk/by-uuid/1f31f2d7-043c-4bbf-8a3e-5e575a8c398a";
-      fsType = "ext4";
-    };
-
-  fileSystems."/mnt/sdf" =
-    { device = "/dev/disk/by-uuid/a09a20e9-7265-4976-ba8f-f4848c99e769";
-      fsType = "ext4";
-    };
-
-  fileSystems."/mnt/torrent" =
-    { device = "/dev/disk/by-uuid/c720dc91-0f69-4dca-88c5-ef36ec0d69e8";
-      fsType = "ext4";
-    };
-
-  fileSystems."/var/lib/matrix-synapse" =
-    { device = "/dev/disk/by-uuid/1089e10b-8951-411b-9103-110349d08d10";
-      fsType = "ext4";
-    };
-
-  fileSystems."/data/nginx/html_thearcanebrony/torrents" =
-    { device = "/mnt/torrent";
-      fsType = "none";
-      options = [ "bind" ];
-    };
-
-  swapDevices = [ ];
-
-  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
-  # (the default) this is the recommended approach. When using systemd-networkd it's
-  # still possible to use this option, but it's recommended to use it in conjunction
-  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
-  networking.useDHCP = lib.mkDefault true;
-  # networking.interfaces.ens18.useDHCP = lib.mkDefault true;
-  # networking.interfaces.ens19.useDHCP = lib.mkDefault true;
-  # networking.interfaces.ve-matrixunlB21.useDHCP = lib.mkDefault true;
-  # networking.interfaces.ve-pluralcoZ833.useDHCP = lib.mkDefault true;
-
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}