summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index b8c8b6d..cde1e7b 100755
--- a/flake.nix
+++ b/flake.nix
@@ -39,6 +39,11 @@
       url = "github:Nheko-reborn/mtxclient/master";
       flake = false;
     };
+
+    # DO NOT TOUCH THIS UNGODLY MESS
+    #nix-ld.url = "github:Mic92/nix-ld";
+    # this line assume that you also have nixpkgs as an input
+    #nix-ld.inputs.nixpkgs.follows = "nixpkgs";
   };
 
   outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl, ... }@inputs: {
@@ -78,6 +83,12 @@
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
           ({...}: { nix.registry.nixpkgs.flake = nixpkgs; })
+          # ... add this line to the rest of your configuration modules
+          #nix-ld.nixosModules.nix-ld
+
+          # The module in this repository defines a new module under (programs.nix-ld.dev) instead of (programs.nix-ld) 
+          # to not collide with the nixpkgs version.
+          #{ programs.nix-ld.dev.enable = true; }
         ];
         specialArgs = {
           inherit home-manager;