summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 5ac075e..d4cb7ea 100755
--- a/flake.nix
+++ b/flake.nix
@@ -34,6 +34,7 @@
     # Sources...
     nhekoSrc = {
       url = "github:Nheko-reborn/nheko/master";
+      #url = "github:q234rty/nheko/b34bce70a4b6572330a6abcfe7b75ce123567f1e";
       flake = false;
     };
     mtxclientSrc = {
@@ -83,7 +84,14 @@
           ./host/Rory-desktop/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
-          ({...}: { nix.registry.nixpkgs.flake = nixpkgs; })
+          ({...}: { 
+            nix = {
+              registry.nixpkgs.flake = nixpkgs;
+              nixPath = [
+                "nixpkgs=${nixpkgs.outPath}"
+              ];
+            };
+          })
           # ... add this line to the rest of your configuration modules
           #nix-ld.nixosModules.nix-ld