summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix26
1 files changed, 19 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index a6a64bb..dc5d08d 100755
--- a/flake.nix
+++ b/flake.nix
@@ -15,15 +15,14 @@
 
   outputs = { self, nixpkgs, home-manager, botcore-v4 }: {
     nixosConfigurations = {
-      Rory-discordbots = nixpkgs.lib.nixosSystem {
+      Rory-nginx = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
-          ./host/Rory-discordbots/configuration.nix
+          ./host/Rory-nginx/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
         ];
         specialArgs = {
-          inherit botcore-v4;
           inherit home-manager;
         };
       };
@@ -38,10 +37,10 @@
           inherit home-manager;
         };
       };
-      Rory-devenv = nixpkgs.lib.nixosSystem {
+      Rory-synapse = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
-          ./host/Rory-devenv/configuration.nix
+          ./host/Rory-synapse/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
         ];
@@ -49,10 +48,22 @@
           inherit home-manager;
         };
       };
-      Rory-nginx = nixpkgs.lib.nixosSystem {
+      Rory-discordbots = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
-          ./host/Rory-nginx/configuration.nix
+          ./host/Rory-discordbots/configuration.nix
+          ./hardware-configuration.nix
+          home-manager.nixosModules.home-manager
+        ];
+        specialArgs = {
+          inherit botcore-v4;
+          inherit home-manager;
+        };
+      };
+      Rory-devenv = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          ./host/Rory-devenv/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
         ];
@@ -60,6 +71,7 @@
           inherit home-manager;
         };
       };
+      
     };
   };
 }