summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 752aece..a64698f 100755
--- a/flake.nix
+++ b/flake.nix
@@ -14,9 +14,6 @@
       #url = "github:NixOS/nixpkgs/nixos-23.05";
       url = "github:NixOS/nixpkgs/nixos-23.11";
     };
-    botcore-v4 = {
-      url = "gitlab:BotCore-Devs/BotCore-v4/staging";
-    };
     home-manager =  {
       url = "github:nix-community/home-manager/master";
     };
@@ -31,6 +28,16 @@
     nixos-wsl.url = "github:nix-community/NixOS-WSL";
     #inputs.nur.url = github:nix-community/NUR;
 
+    # Own projects
+
+    botcore-v4 = {
+      url = "gitlab:BotCore-Devs/BotCore-v4/staging";
+    };
+
+    MatrixMediaGate = {
+      url = "git+https://cgit.rory.gay/matrix/MatrixMediaGate.git/";
+    };
+
     # Sources...
     nhekoSrc = {
       url = "github:Nheko-reborn/nheko/master";
@@ -41,14 +48,9 @@
       url = "github:Nheko-reborn/mtxclient/master";
       flake = false;
     };
-
-    # DO NOT TOUCH THIS UNGODLY MESS
-    #nix-ld.url = "github:Mic92/nix-ld";
-    # this line assume that you also have nixpkgs as an input
-    #nix-ld.inputs.nixpkgs.follows = "nixpkgs";
   };
 
-  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl, ... }@inputs: {
+  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, MatrixMediaGate, conduit, nixos-wsl, ... }@inputs: {
     nixosConfigurations = {
       #NIXPKGS FORK
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
@@ -62,6 +64,7 @@
           inherit botcore-v4;
           inherit home-manager;
           inherit conduit;
+          inherit MatrixMediaGate;
         };
       };