summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--[-rwxr-xr-x]flake.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 965913c..1a4eb5f 100755..100644
--- a/flake.nix
+++ b/flake.nix
@@ -27,9 +27,10 @@
       # will probably also require you to always build from source.
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    nixos-wsl.url = "github:nix-community/NixOS-WSL";
   };
 
-  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit }: {
+  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl }: {
     nixosConfigurations = {
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
         system = "x86_64-linux";
@@ -55,6 +56,8 @@
           inherit home-manager;
         };
       };
+
+      #STABLE
       RoryNix = nixpkgs-RoryNix.lib.nixosSystem {
         system = "i686-linux";
         modules = [
@@ -63,6 +66,17 @@
           ({...}: { nix.registry.nixpkgs.flake = nixpkgs-RoryNix; })
         ];
       };
+
+      #WSL
+      Rory-wsl = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          nixos-wsl.nixosModules.default
+          ./host/Rory-wsl/configuration.nix
+          ./hardware-configuration.nix
+	  home-manager.nixosModules.home-manager
+      ];
+      };
     };
   };
 }