summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix59
1 files changed, 58 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7d6284c..1940892 100755
--- a/flake.nix
+++ b/flake.nix
@@ -23,6 +23,8 @@
 
     # Draupnir module/package
     nixpkgs-Draupnir.url = "github:TheArcaneBrony/nixpkgs/master";
+    nixpkgs-keydb.url = "github:nixos/nixpkgs?rev=e0464e47880a69896f0fb1810f00e0de469f770a";
+    #MatrixContentFilter.url = "git+file:/home/Rory/git/matrix/MatrixContentFilter?submodules=1";
 
     # Base modules
     home-manager.url = "github:nix-community/home-manager/master";
@@ -50,6 +52,11 @@
       url = "github:Nheko-reborn/mtxclient/master";
       flake = false;
     };
+
+    draupnirSrc = {
+      url = "github:the-draupnir-project/Draupnir/main";
+      flake = false;
+    };
   };
 
   outputs =
@@ -57,7 +64,47 @@
     with inputs;
     {
       nixosConfigurations = {
-        #NIXPKGS FORK
+        micro = nixpkgs.lib.nixosSystem {
+          system = "x86_64-linux";
+          modules = [
+            ./hardware-configuration.nix
+            #MatrixContentFilter.modules.default
+
+            (
+              { ... }:
+              {
+                boot.isContainer = true;
+                system.stateVersion = "0";
+                #services.MatrixContentFilter = {
+                #  enable = true;
+                #  accessTokenPath = "/";
+                #  appSettings = {
+                #    "Logging" = {
+                #      "LogLevel" = {
+                #        "Default" = "Debug";
+                #        "System" = "Information";
+                #        "Microsoft" = "Information";
+                #      };
+                #    };
+                #    "LibMatrixBot" = {
+                #      "Homeserver" = "rory.gay";
+                #      "Prefixes" = [
+                #        "!mcf "
+                #      ];
+                #      "MentionPrefix" = false;
+                #    };
+                #    "MatrixContentFilter" = {
+                #      Admins = [ "@emma:rory.gay" ];
+                #    };
+                #  };
+                #};
+              }
+            )
+          ];
+          #specialArgs = {
+          #  inherit home-manager;
+          #};
+        };
         Rory-nginx = nixpkgs.lib.nixosSystem {
           system = "x86_64-linux";
           modules = [
@@ -65,6 +112,7 @@
             ./hardware-configuration.nix
             home-manager.nixosModules.home-manager
             grapevine.nixosModules.default
+            #MatrixContentFilter.modules.default
 
             # these arent really modules...
             botcore-v4.modules.bots
@@ -84,6 +132,7 @@
                   (final: prev: {
                     matrix-synapse-unwrapped = inputs.nixpkgs-master.legacyPackages.${pkgs.stdenv.hostPlatform.system}.matrix-synapse-unwrapped;
                     draupnir = inputs.nixpkgs-Draupnir.legacyPackages.${pkgs.stdenv.hostPlatform.system}.draupnir;
+                    keydb = inputs.nixpkgs-keydb.legacyPackages.${pkgs.stdenv.hostPlatform.system}.keydb;
                   })
                 ];
               }
@@ -96,6 +145,8 @@
             inherit conduit;
             inherit nixpkgs-Draupnir;
             #inherit conduwuit;
+
+            inherit (inputs) draupnirSrc;
           };
         };
 
@@ -212,6 +263,12 @@
         );
 
         packages.mtxclient-git = (pkgs.callPackage ./modules/packages/mtxclient-git.nix { inherit mtxclientSrc; });
+
+        # untested
+        packages.draupnir-main = pkgs.draupnir.overrideAttrs (oldAttrs: {
+          src = draupnirSrc;
+          version = draupnirSrc.rev;
+        });
       }
     );
 }