summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7d6284c..de69e78 100755
--- a/flake.nix
+++ b/flake.nix
@@ -50,6 +50,11 @@
       url = "github:Nheko-reborn/mtxclient/master";
       flake = false;
     };
+
+    draupnirSrc = {
+      url = "github:the-draupnir-project/Draupnir/main";
+      flake = false;
+    };
   };
 
   outputs =
@@ -96,6 +101,8 @@
             inherit conduit;
             inherit nixpkgs-Draupnir;
             #inherit conduwuit;
+            
+            inherit (inputs) draupnirSrc;
           };
         };
 
@@ -212,6 +219,12 @@
         );
 
         packages.mtxclient-git = (pkgs.callPackage ./modules/packages/mtxclient-git.nix { inherit mtxclientSrc; });
+        
+        # untested
+        packages.draupnir-main = pkgs.draupnir.overrideAttrs (oldAttrs: {
+          src = draupnirSrc;
+          version = draupnirSrc.rev;
+        });
       }
     );
 }