summary refs log tree commit diff
path: root/modules/packages/gitfs.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-03-10 15:08:17 +0000
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-03-10 15:08:17 +0000
commit0c3e7bd40976062943c1b7916611b4f853bbac21 (patch)
tree760d7c601eabeebb5e3449c5a164e7e215835c4b /modules/packages/gitfs.nix
parentAdd gitfs patch (diff)
downloadRory-Open-Architecture-0c3e7bd40976062943c1b7916611b4f853bbac21.tar.xz
Update flake
Diffstat (limited to 'modules/packages/gitfs.nix')
-rwxr-xr-xmodules/packages/gitfs.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/modules/packages/gitfs.nix b/modules/packages/gitfs.nix
index 89bb2e2..804a747 100755
--- a/modules/packages/gitfs.nix
+++ b/modules/packages/gitfs.nix
@@ -2,13 +2,16 @@
 {
   environment.systemPackages = with pkgs; [
     (gitfs.overrideAttrs (old: {
-      patches = (old.patches or []) ++ [
-        (fetchpatch {
-          name = "fix-MutableMapping.patch";
-          url = "https://patch-diff.githubusercontent.com/raw/presslabs/gitfs/pull/382.diff";
-          hash = "sha256-ZaIEhv37sorSq3P+6GeH346u/5xh3qE+49D9FRNujMQ=";
-        })
-      ];
+  # TODO: pls fix the nixpkgs derivation
+  patchPhase = null;
+  postPatch = old.patchPhase;
+  patches = (old.patches or []) ++ [
+    (fetchpatch {
+      name = "fix-MutableMapping.patch";
+      url = "https://patch-diff.githubusercontent.com/raw/presslabs/gitfs/pull/382.diff";
+      hash = "sha256-ZaIEhv37sorSq3P+6GeH346u/5xh3qE+49D9FRNujMQ=";
     })
+  ];
+})
   )];
 }