summary refs log tree commit diff
path: root/modules/base.nix
diff options
context:
space:
mode:
authorRory&::Emma <root@rory.gay>2023-08-06 23:49:43 +0000
committerRory&::Emma <root@rory.gay>2023-08-06 23:49:43 +0000
commit15cc356317a7771d26755b367dc58b2d2f7829e6 (patch)
tree2f7aa5ed1247c689a62025be644b455efadbdecc /modules/base.nix
parentSynapse funkery (diff)
downloadRory-Open-Architecture-15cc356317a7771d26755b367dc58b2d2f7829e6.tar.xz
Update stuff
Diffstat (limited to 'modules/base.nix')
-rwxr-xr-xmodules/base.nix32
1 files changed, 28 insertions, 4 deletions
diff --git a/modules/base.nix b/modules/base.nix
index b0e1d95..ffc08f9 100755
--- a/modules/base.nix
+++ b/modules/base.nix
@@ -6,7 +6,12 @@
       ./packages/vim.nix
       ./users/Rory.nix
     ];
-  boot.kernelParams = [ "memory_hotplug.memmap_on_memory=1" "memhp_default_state=online" ];
+  boot.kernelParams = [ 
+    "memory_hotplug.memmap_on_memory=1"
+    "memhp_default_state=online"
+    "net.core.default_qdisc=fq"
+    "net.ipv4.tcp_congestion_control=bbr"
+  ];
   networking = {
     hostName = lib.mkDefault "Rory-nix-base";
     firewall = {
@@ -29,8 +34,13 @@
     };	
   };
 
-  sound.enable = lib.mkDefault true;
-  hardware.pulseaudio.enable = lib.mkDefault true;
+
+  systemd = {
+    sleep.extraConfig = ''
+      AllowSuspend=no
+      AllowHibernation=no
+      '';
+  };
 
   environment.systemPackages = with pkgs; [
     wget
@@ -47,12 +57,26 @@
     neovim
 #    vimPlugins.vim-nix
     tmux
+    jq
+    yq
+    pv
+    dig
+    cloud-utils
   ];
 
   systemd.coredump.extraConfig = lib.mkDefault ''
     Storage=none
   '';
-
+  nix.settings.trusted-substituters = [
+    "https://nix-community.cachix.org"
+    "https://cache.garnix.io"
+    "https://numtide.cachix.org"
+  ];
+  nix.settings.trusted-public-keys = [
+    "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
+    "cache.garnix.io:CTFPyKSLcx5RMJKfLo5EEPUObbA78b0YQ2DTCJXqr9g="
+    "numtide.cachix.org-1:2ps1kLBUWjxIneOy1Ik6cQjb41X0iXVXeHigGmycPPE="
+  ];
   nix.settings.experimental-features = [ "nix-command" "flakes" ];
   nixpkgs.config.allowUnfree = true;
   security.sudo.wheelNeedsPassword = false;