summary refs log tree commit diff
path: root/modules/base-server.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-02-11 22:16:05 +0100
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-02-11 22:16:05 +0100
commit360a5f657eeb55d448d288b1936a9f1c5583d998 (patch)
tree3fcf62c64d07cc492c07cdc6fa22256550f51bcd /modules/base-server.nix
parentFix promtail (diff)
downloadRory-Open-Architecture-360a5f657eeb55d448d288b1936a9f1c5583d998.tar.xz
Check your braces, girl
Signed-off-by: TheArcaneBrony <myrainbowdash949@gmail.com>
Diffstat (limited to 'modules/base-server.nix')
-rw-r--r--modules/base-server.nix54
1 files changed, 27 insertions, 27 deletions
diff --git a/modules/base-server.nix b/modules/base-server.nix
index 4751bd8..a23a034 100644
--- a/modules/base-server.nix
+++ b/modules/base-server.nix
@@ -23,7 +23,7 @@
   };
 
   networking = {
-	  hostName = lib.mkDefault "Rory-nix-base-server";
+    hostName = lib.mkDefault "Rory-nix-base-server";
     networkmanager.enable = false;
     wireless.enable = false;
     enableIPv6 = false;
@@ -61,34 +61,34 @@
           ];
         };
       };
-      promtail = {
-        enable = true;
-        configuration = {
-          server = {
-            http_listen_port = 3031;
-            grpc_listen_port = 0;
-          };
-          positions = {
-            filename = "/tmp/positions.yaml";
-          };
-          clients = [{
-            url = "https://loki.regional.seian.cloud/loki/api/v1/push";
-          }];
-          scrape_configs = [{
-            job_name = "journal";
-            journal = {
-              max_age = "12h";
-              labels = {
-                job = "systemd-journal";
-                host = "${toString config.networking.hostName}";
-              };
+    };
+    promtail = {
+      enable = true;
+      configuration = {
+        server = {
+          http_listen_port = 3031;
+          grpc_listen_port = 0;
+        };
+        positions = {
+          filename = "/tmp/positions.yaml";
+        };
+        clients = [{
+          url = "https://loki.regional.seian.cloud/loki/api/v1/push";
+        }];
+        scrape_configs = [{
+          job_name = "journal";
+          journal = {
+            max_age = "12h";
+            labels = {
+              job = "systemd-journal";
+              host = "${toString config.networking.hostName}";
             };
-            relabel_configs = [{
-              source_labels = [ "__journal__systemd_unit" ];
-              target_label = "unit";
-            }];
+          };
+          relabel_configs = [{
+            source_labels = [ "__journal__systemd_unit" ];
+            target_label = "unit";
           }];
-        };
+        }];
       };
     };
   };