summary refs log tree commit diff
path: root/host/Rory-portable/printing.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-07-04 14:59:36 +0200
committerRory& <root@rory.gay>2024-07-04 14:59:36 +0200
commitdd7b872694441a96b8b042ccbc4b63a96d0b89b9 (patch)
tree76a25875e08415c38cdb7b5ad8f93241b387d078 /host/Rory-portable/printing.nix
parentUpdate flake inputs (diff)
downloadRory-Open-Architecture-dd7b872694441a96b8b042ccbc4b63a96d0b89b9.tar.xz
Nixfmt
Diffstat (limited to 'host/Rory-portable/printing.nix')
-rw-r--r--host/Rory-portable/printing.nix18
1 files changed, 14 insertions, 4 deletions
diff --git a/host/Rory-portable/printing.nix b/host/Rory-portable/printing.nix
index fd33aaa..2480610 100644
--- a/host/Rory-portable/printing.nix
+++ b/host/Rory-portable/printing.nix
@@ -1,11 +1,19 @@
-{ config, pkgs, lib, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
 
 {
   imports = [ ];
 
   users.users = {
     Rory = {
-      extraGroups = [ "lp" "scanner" ];
+      extraGroups = [
+        "lp"
+        "scanner"
+      ];
     };
   };
 
@@ -16,7 +24,10 @@
 
   hardware = {
     sane.enable = true;
-    sane.extraBackends = [ pkgs.hplipWithPlugin pkgs.sane-airscan ];
+    sane.extraBackends = [
+      pkgs.hplipWithPlugin
+      pkgs.sane-airscan
+    ];
   };
 
   programs.system-config-printer.enable = true;
@@ -48,4 +59,3 @@
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }
-