summary refs log tree commit diff
path: root/host/Rory-portable/optional/hardware-specific/amd.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-07-04 14:59:36 +0200
committerRory& <root@rory.gay>2024-07-04 14:59:36 +0200
commitdd7b872694441a96b8b042ccbc4b63a96d0b89b9 (patch)
tree76a25875e08415c38cdb7b5ad8f93241b387d078 /host/Rory-portable/optional/hardware-specific/amd.nix
parentUpdate flake inputs (diff)
downloadRory-Open-Architecture-dd7b872694441a96b8b042ccbc4b63a96d0b89b9.tar.xz
Nixfmt
Diffstat (limited to 'host/Rory-portable/optional/hardware-specific/amd.nix')
-rw-r--r--host/Rory-portable/optional/hardware-specific/amd.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/host/Rory-portable/optional/hardware-specific/amd.nix b/host/Rory-portable/optional/hardware-specific/amd.nix
index e24bcd0..4456c6f 100644
--- a/host/Rory-portable/optional/hardware-specific/amd.nix
+++ b/host/Rory-portable/optional/hardware-specific/amd.nix
@@ -1,10 +1,16 @@
-{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  nhekoSrc,
+  mtxclientSrc,
+  ...
+}:
 
 {
-  imports =
-    [ ];
+  imports = [ ];
 
-boot.initrd.kernelModules = [ "amdgpu" ];
+  boot.initrd.kernelModules = [ "amdgpu" ];
 
   services = {
     xserver = {
@@ -29,16 +35,11 @@ boot.initrd.kernelModules = [ "amdgpu" ];
         rocmPackages.clr.icd
         amdvlk
       ];
-      extraPackages32 = with pkgs; [
-        driversi686Linux.amdvlk
-      ];
+      extraPackages32 = with pkgs; [ driversi686Linux.amdvlk ];
     };
   };
 
-  systemd.tmpfiles.rules = [
-    "L+    /opt/rocm/hip   -    -    -     -    ${pkgs.rocmPackages.clr}"
-  ];
+  systemd.tmpfiles.rules = [ "L+    /opt/rocm/hip   -    -    -     -    ${pkgs.rocmPackages.clr}" ];
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }
-