summary refs log tree commit diff
path: root/host/Rory-nginx/services/nginx/rory.gay/wad-api.nix
diff options
context:
space:
mode:
authorRory&::Emma <root@rory.gay>2024-08-24 14:16:55 +0000
committerRory&::Emma <root@rory.gay>2024-08-24 14:16:55 +0000
commitf3cbaf4b9b18fb49314c269f8efac2302c0c45cb (patch)
tree117d3d00e1101ef6b61e3bf3632236074aef6e64 /host/Rory-nginx/services/nginx/rory.gay/wad-api.nix
parentFix MUT wipe service (diff)
downloadRory-Open-Architecture-f3cbaf4b9b18fb49314c269f8efac2302c0c45cb.tar.xz
Server changes
Diffstat (limited to 'host/Rory-nginx/services/nginx/rory.gay/wad-api.nix')
-rwxr-xr-xhost/Rory-nginx/services/nginx/rory.gay/wad-api.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/nginx/rory.gay/wad-api.nix b/host/Rory-nginx/services/nginx/rory.gay/wad-api.nix
new file mode 100755
index 0000000..65e9bdb
--- /dev/null
+++ b/host/Rory-nginx/services/nginx/rory.gay/wad-api.nix
@@ -0,0 +1,32 @@
+{
+  enableACME = true;
+  addSSL = true;
+  locations = {
+    "/" = {
+      proxyPass = "https://youthapp.inuits.dev";
+      recommendedProxySettings = false;
+      extraConfig = ''
+        proxy_ssl_verify off;
+        proxy_set_header Host youthapp.inuits.dev;
+        proxy_ssl_server_name on;
+
+          more_set_headers 'Access-Control-Allow-Origin: *';
+          more_set_headers 'Access-Control-Allow-Methods: *';
+          #
+          # Custom headers and headers various browsers *should* be OK with but aren't
+          #
+          more_set_headers 'Access-Control-Allow-Headers: *, Authorization';
+          #
+          # Tell client that this pre-flight info is valid for 20 days
+          # 
+          more_set_headers 'Access-Control-Max-Age: 1728000';
+
+        if ($request_method = 'OPTIONS') {
+          more_set_headers 'Content-Type: text/plain; charset=utf-8';
+          more_set_headers 'Content-Length: 0';
+          return 204;
+        }
+      '';
+    };
+  };
+}