summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/sync.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-08-16 12:16:21 +0200
committerRory& <root@rory.gay>2024-08-16 12:16:21 +0200
commit9778db57511950cda9d5c0f8955597d6b2282302 (patch)
treee946d27d44b425986240dd731afea7944894df1a /host/Rory-nginx/services/matrix/synapse/workers/sync.nix
parentNginx log request times (diff)
downloadRory-Open-Architecture-9778db57511950cda9d5c0f8955597d6b2282302.tar.xz
Some synapse workers cleanup
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/sync.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/sync.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/sync.nix b/host/Rory-nginx/services/matrix/synapse/workers/sync.nix
index 579e14b..2655ff3 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/sync.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/sync.nix
@@ -2,9 +2,12 @@
 
 let
   cfg = config.services.matrix-synapse;
+  dbGroup = "small";
+  hasClientResource = false;
+  hasFederationResource = false;
   workers = lib.range 0 (cfg.syncWorkers - 1);
   workerName = "sync";
-  routes = [
+  workerRoutes = [
     "~ ^/_matrix/client/(v2_alpha|r0|v3)/sync$"
     "~ ^/_matrix/client/(api/v1|v2_alpha|r0|v3)/events$"
     "~ ^/_matrix/client/(api/v1|r0|v3)/initialSync$"
@@ -55,8 +58,8 @@ in
             ];
             database = (
               import ../db.nix {
+                inherit dbGroup;
                 workerName = "${workerName}-${toString index}";
-                dbGroup = "small";
               }
             );
           };
@@ -84,7 +87,7 @@ in
         value = {
           proxyPass = "http://${workerName}";
         };
-      }) routes
+      }) workerRoutes
     );
   };
 }