summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-08-17 10:47:57 +0200
committerRory& <root@rory.gay>2024-08-17 10:47:57 +0200
commite6e5f18aa1329325cfcd615b1adc8ae4feb6013a (patch)
tree2b90564bcd310c2f27b8cca940cf5af5c3f6f8b2 /host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
parentevent -> events (diff)
downloadRory-Open-Architecture-e6e5f18aa1329325cfcd615b1adc8ae4feb6013a.tar.xz
Fix synapse paths?
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix85
1 files changed, 59 insertions, 26 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix b/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
index 598c028..cd482f9 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/federation-sender.nix
@@ -2,7 +2,7 @@
 let
   cfg = config.services.matrix-synapse;
   dbGroup = "solo";
-  federationSenders = lib.range 0 (cfg.federationSenders - 1);
+  workers = lib.range 0 (cfg.federationSenders - 1);
   workerName = "federation_sender";
   workerRoutes = {
     client = [ ];
@@ -10,6 +10,9 @@ let
     media = [ ];
   };
 in
+let
+  enabledResources = lib.optionals (lib.length workerRoutes.client > 0) [ "client" ] ++ lib.optionals (lib.length workerRoutes.federation > 0) [ "federation" ] ++ lib.optionals (lib.length workerRoutes.media > 0) [ "media" ];
+in
 {
   config = lib.mkIf (cfg.federationSenders > 0) {
     services.matrix-synapse = {
@@ -20,11 +23,11 @@ in
             value = {
               path = "/run/matrix-synapse/${workerName}-${toString index}.sock";
             };
-          }) federationSenders
+          }) workers
         );
         send_federation = false;
-        federation_sender_instances = lib.map (index: "${workerName}-${toString index}") federationSenders;
-        outbound_federation_restricted_to = lib.map (index: "${workerName}-${toString index}") federationSenders;
+        federation_sender_instances = lib.map (index: "${workerName}-${toString index}") workers;
+        outbound_federation_restricted_to = lib.map (index: "${workerName}-${toString index}") workers;
         worker_replication_secret = "${workerName}_secret";
       };
 
@@ -33,18 +36,30 @@ in
           name = "${workerName}-${toString index}";
           value = {
             worker_app = "synapse.app.generic_worker";
-            worker_listeners = [
-              {
+            worker_listeners =
+              [
+                {
+                  type = "http";
+                  path = "/run/matrix-synapse/${workerName}-${toString index}.sock";
+                  resources = [
+                    {
+                      names = [ "replication" ];
+                      compress = false;
+                    }
+                  ];
+                }
+              ]
+              ++ lib.map (type: {
                 type = "http";
-                path = "/run/matrix-synapse/${workerName}-${toString index}.sock";
+                path = "/run/matrix-synapse/${workerName}-${type}-${toString index}.sock";
+                mode = "666";
                 resources = [
                   {
-                    names = [ "replication" ];
+                    names = [ type ];
                     compress = false;
                   }
                 ];
-              }
-            ];
+              }) enabledResources;
             database = (
               import ../db.nix {
                 inherit dbGroup;
@@ -52,27 +67,45 @@ in
               }
             );
           };
-        }) federationSenders
+        }) workers
       );
     };
     services.nginx = {
-      virtualHosts."${cfg.nginxVirtualHostName}".locations = lib.listToAttrs (
-        lib.flatten (
-          lib.forEach
-            [
-              "client"
-              "federation"
-              "media"
-            ]
-            (
-              type:
-              lib.map (route: {
-                name = route;
+      upstreams = lib.listToAttrs (
+        lib.map (type: {
+          name = "${workerName}-${type}";
+          value = {
+            extraConfig = ''
+              keepalive 32;
+              least_conn;
+            '';
+            servers = lib.listToAttrs (
+              lib.map (index: {
+                name = "unix:/run/matrix-synapse/${workerName}-${type}-${toString index}.sock";
                 value = {
-                  proxyPass = "http://unix:/run/matrix-synapse/${workerName}-${type}.sock";
+                  max_fails = 0;
                 };
-              }) workerRoutes.${type}
-            )
+              }) workers
+            );
+          };
+        }) enabledResources
+      );
+
+      virtualHosts."${cfg.nginxVirtualHostName}".locations = lib.listToAttrs (
+        lib.flatten (
+          lib.forEach enabledResources (
+            type:
+            lib.map (route: {
+              name = route;
+              value = {
+                proxyPass = "http://${workerName}-${type}";
+                extraConfig = ''
+                  proxy_http_version 1.1;
+                  proxy_set_header Connection "";
+                '';
+              };
+            }) workerRoutes.${type}
+          )
         )
       );
     };