summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/auth.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-08-28 21:40:53 +0200
committerRory& <root@rory.gay>2024-08-28 21:40:53 +0200
commit62fb7f7c127ca8aee56b3903ee207dec766d0a11 (patch)
treeac38a9bc6228b990687dcb636dc13080bfbd334f /host/Rory-nginx/services/matrix/synapse/workers/auth.nix
parentDesktop/i686 changes (diff)
downloadRory-Open-Architecture-62fb7f7c127ca8aee56b3903ee207dec766d0a11.tar.xz
Monitoring?
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/auth.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/auth.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/auth.nix b/host/Rory-nginx/services/matrix/synapse/workers/auth.nix
index 50d52c6..3c8d1e9 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/auth.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/auth.nix
@@ -23,10 +23,14 @@ let
   };
 in
 let
-  enabledResources = lib.optionals (lib.length workerRoutes.client > 0) [ "client" ] ++ lib.optionals (lib.length workerRoutes.federation > 0) [ "federation" ] ++ lib.optionals (lib.length workerRoutes.media > 0) [ "media" ];
+  enabledResources =
+    lib.optionals (lib.length workerRoutes.client > 0) [ "client" ]
+    ++ lib.optionals (lib.length workerRoutes.federation > 0) [ "federation" ]
+    ++ lib.optionals (lib.length workerRoutes.media > 0) [ "media" ];
 in
 {
   config = lib.mkIf (cfg.authWorkers > 0) {
+    monitoring.synapse.workerNames = lib.map (index: "${workerName}-${toString index}") workers;
     services.matrix-synapse = {
       settings = {
         instance_map = lib.listToAttrs (