summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/caches.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-06-27 15:02:25 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commite6813744cdedcd157c2c8835a9a5e0649579bcb8 (patch)
treea074d44914cd962a1f1ecabf9dd34a58a29db2f1 /host/Rory-nginx/services/matrix/synapse/caches.nix
parentUse postgres sockets for synapse (diff)
downloadRory-Open-Architecture-e6813744cdedcd157c2c8835a9a5e0649579bcb8.tar.xz
Split up synapse config
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/caches.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/caches.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/caches.nix b/host/Rory-nginx/services/matrix/synapse/caches.nix
new file mode 100644
index 0000000..d129076
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/synapse/caches.nix
@@ -0,0 +1,16 @@
+{
+  gc_min_interval = ["5m" "30m" "60m"];
+  gc_thresholds = [1000 500 250];
+  event_cache_size = "12000K"; #defaults to 10K
+  caches = {
+    global_factor = 50000.0;
+    cache_entry_ttl = "24h";
+    expire_caches = true;
+    sync_response_cache_duration = "15s"; #6h
+    cache_autotuning = {
+      max_cache_memory_usage = "65536M";
+      target_cache_memory_usage = "32768M";
+      min_cache_ttl = "6h";
+    };
+  };
+}
\ No newline at end of file