summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/matrix-appservice-discord.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-08-18 02:53:26 +0200
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-08-18 02:53:26 +0200
commit95ceb640e4de44994c265155464f81e1893dd394 (patch)
treed500f8130892f71c055c16b8cf2dbda771444bf2 /host/Rory-nginx/services/matrix/matrix-appservice-discord.nix
parentUpdate stuff (diff)
downloadRory-Open-Architecture-95ceb640e4de44994c265155464f81e1893dd394.tar.xz
Refactor
Diffstat (limited to 'host/Rory-nginx/services/matrix/matrix-appservice-discord.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/matrix-appservice-discord.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/matrix-appservice-discord.nix b/host/Rory-nginx/services/matrix/matrix-appservice-discord.nix
new file mode 100755
index 0000000..3f2225f
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/matrix-appservice-discord.nix
@@ -0,0 +1,26 @@
+{ config, pkgs, lib, ... }:
+
+{
+  # Discord bridge
+   services.matrix-appservice-discord = {
+    enable = false; # Alicia - figure out secret first...
+    environmentFile = /etc/keyring/matrix-appservice-discord/tokens.env;
+    # The appservice is pre-configured to use SQLite by default.
+    # It's also possible to use PostgreSQL.
+    settings = {
+      bridge = {
+        domain = "rory.gay";
+        homeserverUrl = "https://matrix.rory.gay";
+      };
+
+      # The service uses SQLite by default, but it's also possible to use
+      # PostgreSQL instead:
+      database = {
+        #  filename = ""; # empty value to disable sqlite
+        connString = "postgres://postgres@127.0.0.1/matrix-appservice-discord";
+      };
+    };
+   };
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}
+