summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/grapevine.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-07-03 20:04:37 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commit786eb433a3242934624973fcce6b07323e5fc055 (patch)
treee37bf1ad9de868dff1bc41320479d64f6d7739a8 /host/Rory-nginx/services/matrix/grapevine.nix
parentUpdate flake inputs, disable showing diffs for flake.lock (diff)
downloadRory-Open-Architecture-786eb433a3242934624973fcce6b07323e5fc055.tar.xz
Server cleanup
Diffstat (limited to 'host/Rory-nginx/services/matrix/grapevine.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/grapevine.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/grapevine.nix b/host/Rory-nginx/services/matrix/grapevine.nix
new file mode 100755
index 0000000..700c4bb
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/grapevine.nix
@@ -0,0 +1,33 @@
+{ config, pkgs, lib, ... }:
+
+{
+  services.grapevine = {
+    #package = conduit.packages.${pkgs.system}.default;
+    enable = true;
+    settings = {
+      conduit_compat = true;
+#      address = "127.0.0.1";
+      server_name = "conduit.rory.gay";
+      
+      listen = [
+        {
+          type = "tcp";
+          address = "127.0.0.1";
+          port = 6167;
+        }
+      ];
+
+      database = {
+        backend = "rocksdb";
+      };
+
+      allow_check_for_updates = false;
+      allow_registration = false;
+
+      #log = "info";
+      #log_format = "full";
+      #log = "debug";
+    };
+  };
+}
+