summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/conduit.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-06-22 04:46:02 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commit2c106e7b604c388ddc7578c42998c17403f37620 (patch)
tree8c3486f7bfff4c6f0937919d96cca77d0d1cfeee /host/Rory-nginx/services/matrix/conduit.nix
parentBunch of changes (diff)
downloadRory-Open-Architecture-2c106e7b604c388ddc7578c42998c17403f37620.tar.xz
Desktop updates
Diffstat (limited to 'host/Rory-nginx/services/matrix/conduit.nix')
-rwxr-xr-xhost/Rory-nginx/services/matrix/conduit.nix17
1 files changed, 1 insertions, 16 deletions
diff --git a/host/Rory-nginx/services/matrix/conduit.nix b/host/Rory-nginx/services/matrix/conduit.nix
index e425cc4..eb830ab 100755
--- a/host/Rory-nginx/services/matrix/conduit.nix
+++ b/host/Rory-nginx/services/matrix/conduit.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, lib, conduit, ... }:
+{ config, pkgs, lib, ... }:
 
 {
   services.grapevine = {
@@ -60,20 +60,5 @@
       #log = "debug";
     };
   };
-#  systemd.services.matrix-conduit-reg-token = {
-#      description = "Random registration token for Conduit.";
-#      before = ["grapevine.service"]; # So the registration can be used by Conduit.
-#      after = ["matrix-synapse-reg-token.service"];
-#
-#      script = ''
-#        mkdir -p /run/systemd/system/conduit.service.d
-#        echo Environment=\"CONDUIT_REGISTRATION_TOKEN=$(cat /var/lib/matrix-synapse/registration_shared_secret.txt)\" > /run/systemd/system/grapevine.service.d/override.conf
-#        systemctl daemon-reload'';
-#      serviceConfig = {
-#        User = "root";
-#        Group = "root";
-#      };
-#    };
-
 }