summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-09-06 23:30:26 +0200
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-09-06 23:30:26 +0200
commit40bfa51153bb38e0471ab05937b018d0ba255f0d (patch)
treef25aa0e590e433f5bcff65ad9bf3d94cc74cdccd /host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix
parentAdd changes (diff)
downloadRory-Open-Architecture-40bfa51153bb38e0471ab05937b018d0ba255f0d.tar.xz
Add container
Diffstat (limited to 'host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix b/host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix
new file mode 100755
index 0000000..39f593e
--- /dev/null
+++ b/host/Rory-nginx/services/containers/pluralcontactbotpoc/container.nix
@@ -0,0 +1,28 @@
+{ pkgs, lib, ... }:
+
+{
+#  imports =
+#    [
+#      ./root.nix
+#    ];
+
+    privateNetwork = true;
+    autoStart = true;
+
+
+    # config is root.nix with networking overridden
+    config = import ./root.nix { 
+        inherit config;
+        etc."resolv.conf".text = ''
+            nameserver 8.8.8.8
+            nameserver 8.4.4.8
+            nameserver 1.1.1.1
+            nameserver 1.0.0.1
+        '';
+        networking.firewall = {
+            enable = true;
+            allowedTCPPorts = [ 80 443 ];  
+        };
+    };
+    
+}
\ No newline at end of file