summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/rory.gay/matrix.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-06-28 11:08:57 +0200
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-06-28 11:08:57 +0200
commitb13cb19aa1edb0798e74dc9430b9baf1afa350c4 (patch)
treed79ac9f5d38cf0bb6110210142a01531ce8b1cba /host/Rory-nginx/hosts/rory.gay/matrix.nix
parentUpdate deployed state (diff)
downloadRory-Open-Architecture-b13cb19aa1edb0798e74dc9430b9baf1afa350c4.tar.xz
Switch to headers_more
Diffstat (limited to 'host/Rory-nginx/hosts/rory.gay/matrix.nix')
-rwxr-xr-xhost/Rory-nginx/hosts/rory.gay/matrix.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/host/Rory-nginx/hosts/rory.gay/matrix.nix b/host/Rory-nginx/hosts/rory.gay/matrix.nix
index 0f8420c..0c720bd 100755
--- a/host/Rory-nginx/hosts/rory.gay/matrix.nix
+++ b/host/Rory-nginx/hosts/rory.gay/matrix.nix
@@ -5,18 +5,18 @@
   #   proxyPass = "http://192.168.1.5:8008"; 
   #   extraConfig = ''
   #     if ($request_method = 'OPTIONS') {
-  #       add_header 'Access-Control-Allow-Origin' '*';
-  #       add_header 'Access-Control-Allow-Methods' '*';
+  #       more_set_headers 'Access-Control-Allow-Origin' '*';
+  #       more_set_headers 'Access-Control-Allow-Methods' '*';
   #       #
   #       # Custom headers and headers various browsers *should* be OK with but aren't
   #       #
-  #       add_header 'Access-Control-Allow-Headers' '*';
+  #       more_set_headers 'Access-Control-Allow-Headers' '*';
   #       #
   #       # Tell client that this pre-flight info is valid for 20 days
   #       #
-  #       add_header 'Access-Control-Max-Age' 1728000;
-  #       add_header 'Content-Type' 'text/plain; charset=utf-8';
-  #       add_header 'Content-Length' 0;
+  #       more_set_headers 'Access-Control-Max-Age' 1728000;
+  #       more_set_headers 'Content-Type' 'text/plain; charset=utf-8';
+  #       more_set_headers 'Content-Length' 0;
   #       return 204;
   #     };
   #   '';