summary refs log tree commit diff
path: root/host/Rory-nginx/configuration.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-07-04 14:59:36 +0200
committerRory& <root@rory.gay>2024-07-04 14:59:36 +0200
commitdd7b872694441a96b8b042ccbc4b63a96d0b89b9 (patch)
tree76a25875e08415c38cdb7b5ad8f93241b387d078 /host/Rory-nginx/configuration.nix
parentUpdate flake inputs (diff)
downloadRory-Open-Architecture-dd7b872694441a96b8b042ccbc4b63a96d0b89b9.tar.xz
Nixfmt
Diffstat (limited to 'host/Rory-nginx/configuration.nix')
-rwxr-xr-xhost/Rory-nginx/configuration.nix78
1 files changed, 46 insertions, 32 deletions
diff --git a/host/Rory-nginx/configuration.nix b/host/Rory-nginx/configuration.nix
index 648d8d5..b85a75e 100755
--- a/host/Rory-nginx/configuration.nix
+++ b/host/Rory-nginx/configuration.nix
@@ -1,43 +1,57 @@
-{ config, pkgs, lib, grapevine, conduit, conduwuit, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  grapevine,
+  conduit,
+  conduwuit,
+  ...
+}:
 
 {
-  imports =
-    [
-      ../../modules/base-server.nix
-      ../../modules/users/levi.nix
-      ../../modules/users/db2k.nix
-      ../../modules/users/ks.nix
-      ../../modules/users/Alice.nix
+  imports = [
+    ../../modules/base-server.nix
+    ../../modules/users/levi.nix
+    ../../modules/users/db2k.nix
+    ../../modules/users/ks.nix
+    ../../modules/users/Alice.nix
 
-      ./services/postgres.nix
-      ./services/discordbots.nix
-      ./services/matrix/root.nix
-      ./services/nginx/nginx.nix
-      #./services/jitsi.nix
-      ./services/cgit.nix
-      #./services/ollama.nix
-      ./services/prometheus.nix
-    ];
-  users.groups.ocp = {};
+    ./services/postgres.nix
+    ./services/discordbots.nix
+    ./services/matrix/root.nix
+    ./services/nginx/nginx.nix
+    #./services/jitsi.nix
+    ./services/cgit.nix
+    #./services/ollama.nix
+    ./services/prometheus.nix
+  ];
+  users.groups.ocp = { };
   networking = {
     hostName = "Rory-nginx";
-    interfaces.ens18.ipv4.addresses = [ { 
-      address = "192.168.1.2";
-      prefixLength = 24;
-    } ];
-    interfaces.ens19.ipv4.addresses = [ {
-      address = "10.10.10.2";
-      prefixLength = 16;
-    } ];
+    interfaces.ens18.ipv4.addresses = [
+      {
+        address = "192.168.1.2";
+        prefixLength = 24;
+      }
+    ];
+    interfaces.ens19.ipv4.addresses = [
+      {
+        address = "10.10.10.2";
+        prefixLength = 16;
+      }
+    ];
     defaultGateway.interface = "ens18";
-#    extraHosts = ''
-#      127.0.0.1 rory.gay
-#      127.0.0.1 matrix.rory.gay
-#      127.0.0.1 conduit.rory.gay
-#      '';
+    #    extraHosts = ''
+    #      127.0.0.1 rory.gay
+    #      127.0.0.1 matrix.rory.gay
+    #      127.0.0.1 conduit.rory.gay
+    #      '';
     nat = {
       enable = true;
-      internalInterfaces = [ "ve-+" "vb-+" ];
+      internalInterfaces = [
+        "ve-+"
+        "vb-+"
+      ];
       externalInterface = "ens18";
       #enableIPv6 = true;
     };