summary refs log tree commit diff
path: root/host/Rory-desktop/nginx.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-12-14 07:24:04 +0100
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-12-14 07:24:55 +0100
commitd935a4f3e1d67152149945adc31b7886ccf37701 (patch)
treeae4d39bda4c767b4675d6477c7d9c3ed88939237 /host/Rory-desktop/nginx.nix
parentUpdate synapse cache settings (diff)
downloadRory-Open-Architecture-d935a4f3e1d67152149945adc31b7886ccf37701.tar.xz
Desktop updates
Diffstat (limited to 'host/Rory-desktop/nginx.nix')
-rw-r--r--host/Rory-desktop/nginx.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/host/Rory-desktop/nginx.nix b/host/Rory-desktop/nginx.nix
new file mode 100644
index 0000000..fc2adca
--- /dev/null
+++ b/host/Rory-desktop/nginx.nix
@@ -0,0 +1,39 @@
+{ config, pkgs, lib, ... }:
+
+{
+  services = {
+    nginx = {
+      enable = true;
+      #package = pkgs.nginxQuic;
+      recommendedProxySettings = true;
+      #recommendedTlsSettings = true;
+      recommendedZstdSettings = true;
+      recommendedGzipSettings = true;
+      recommendedBrotliSettings = true;
+      recommendedOptimisation = true;
+      #defaultMimeTypes = ../../../../modules/packages/nginx/mime.types;
+      appendConfig = ''
+        worker_processes 16;
+        '';
+       eventsConfig = ''
+        #use kqueue;
+        worker_connections 512;
+        '';
+      appendHttpConfig = ''
+        #sendfile on;
+        disable_symlinks off;
+      '';
+      additionalModules = with pkgs.nginxModules; [
+        moreheaders
+      ];
+      virtualHosts = {
+        "discord.localhost" = import ./nginx/discord.localhost.nix { inherit pkgs; };
+        
+      };
+    };
+  };
+  systemd.services.nginx.serviceConfig = {
+    LimitNOFILE=5000000;
+  };
+
+}