summary refs log tree commit diff
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
authorEmma (Rory&) <root@rory.gay>2023-09-28 15:56:29 +0000
committerEmma (Rory&) <root@rory.gay>2023-09-28 15:56:29 +0000
commitb2c4d04963c89846e03c6e8080e7418d7daed59e (patch)
tree7d52785d6fa87ab1a9416128a76e72fd8df2b255 /hardware-configuration.nix
parentFormatting changes (diff)
downloadRory-Open-Architecture-b2c4d04963c89846e03c6e8080e7418d7daed59e.tar.xz
Add WSL config
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix74
1 files changed, 74 insertions, 0 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
new file mode 100644
index 0000000..1332e7a
--- /dev/null
+++ b/hardware-configuration.nix
@@ -0,0 +1,74 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports = [ ];
+
+  boot.initrd.availableKernelModules = [ "virtio_pci" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/111f8fcb-03cc-4804-98bd-e8c41567dd09";
+      fsType = "ext4";
+    };
+
+  fileSystems."/usr/lib/wsl/drivers" =
+    { device = "none";
+      fsType = "9p";
+    };
+
+  fileSystems."/usr/lib/wsl/lib" =
+    { device = "none";
+      fsType = "overlay";
+    };
+
+  fileSystems."/mnt/wsl" =
+    { device = "none";
+      fsType = "tmpfs";
+    };
+
+  fileSystems."/mnt/wslg" =
+    { device = "none";
+      fsType = "tmpfs";
+    };
+
+  fileSystems."/mnt/wslg/distro" =
+    { device = "";
+      fsType = "none";
+      options = [ "bind" ];
+    };
+
+  fileSystems."/mnt/wslg/doc" =
+    { device = "none";
+      fsType = "overlay";
+    };
+
+  fileSystems."/tmp/.X11-unix" =
+    { device = "/mnt/wslg/.X11-unix";
+      fsType = "none";
+      options = [ "bind" ];
+    };
+
+  fileSystems."/mnt/c" =
+    { device = "drvfs";
+      fsType = "9p";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/c3f339c1-3c4d-48a3-991a-1c370c276e49"; }
+    ];
+
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.bonding_masters.useDHCP = lib.mkDefault true;
+  # networking.interfaces.eth0.useDHCP = lib.mkDefault true;
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}