summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-09-05 22:49:11 +0200
committerRory& <root@rory.gay>2024-09-05 22:49:11 +0200
commited39a6bf2da6ad1790895a1e824e74186aefc4bd (patch)
tree15799c872c7c48dbc1dacfb17e842e04ff33a1f8 /flake.nix
parentLess synapse workers, add EDU writers (diff)
downloadRory-Open-Architecture-ed39a6bf2da6ad1790895a1e824e74186aefc4bd.tar.xz
Some synapse work, expose nheko-git and mtxclient-git packages
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix24
1 files changed, 22 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index bcef2ce..6b9576a 100755
--- a/flake.nix
+++ b/flake.nix
@@ -22,6 +22,7 @@
     # Base modules
     home-manager.url = "github:nix-community/home-manager/master";
     sops-nix.url = "github:Mic92/sops-nix";
+    flake-utils.url = "github:numtide/flake-utils";
 
     # Packages
     grapevine.url = "gitlab:matrix/grapevine-fork?host=gitlab.computer.surgery"; # &ref=benjamin/debug-emma-kde-room";
@@ -47,7 +48,9 @@
   };
 
   outputs =
-    inputs: with inputs; {
+    inputs:
+    with inputs;
+    {
       nixosConfigurations = {
         #NIXPKGS FORK
         Rory-nginx = nixpkgs.lib.nixosSystem {
@@ -199,5 +202,22 @@
           };
         };
       };
-    };
+    }
+    // flake-utils.lib.eachSystem flake-utils.lib.allSystems (
+      system:
+      let
+        pkgs = import nixpkgs { inherit system; };
+      in
+      {
+        packages.nheko-git = (
+          pkgs.callPackage ./modules/packages/nheko-git.nix {
+            inherit nhekoSrc;
+            inherit mtxclientSrc;
+            voipSupport = false;
+          }
+        );
+
+        packages.mtxclient-git = (pkgs.callPackage ./modules/packages/mtxclient-git.nix { inherit mtxclientSrc; });
+      }
+    );
 }