summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-08-18 02:53:26 +0200
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-08-18 02:53:26 +0200
commit95ceb640e4de44994c265155464f81e1893dd394 (patch)
treed500f8130892f71c055c16b8cf2dbda771444bf2 /flake.nix
parentUpdate stuff (diff)
downloadRory-Open-Architecture-95ceb640e4de44994c265155464f81e1893dd394.tar.xz
Refactor
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix48
1 files changed, 10 insertions, 38 deletions
diff --git a/flake.nix b/flake.nix
index 17fc916..1273d08 100755
--- a/flake.nix
+++ b/flake.nix
@@ -12,6 +12,15 @@
     home-manager =  {
       url = "github:nix-community/home-manager/master";
     };
+    conduit = {
+      url = "gitlab:famedly/conduit";
+
+      # Assuming you have an input for nixpkgs called `nixpkgs`. If you experience
+      # build failures while using this, try commenting/deleting this line. This
+      # will probably also require you to always build from source.
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
   };
 
   outputs = { self, nixpkgs, home-manager, botcore-v4 }: {
@@ -21,48 +30,12 @@
         modules = [
           ./host/Rory-nginx/configuration.nix
           ./hardware-configuration.nix
-          ./host/Rory-discordbots/software.nix
-          ./host/Rory-synapse/software.nix
-	  ./host/Rory-postgres/software.nix
-          home-manager.nixosModules.home-manager
-        ];
-        specialArgs = {
-          inherit botcore-v4;
-          inherit home-manager;
-        };
-      };
-      Rory-postgres = nixpkgs.lib.nixosSystem {
-        system = "x86_64-linux";
-        modules = [
-          ./host/Rory-postgres/configuration.nix
-          ./hardware-configuration.nix
-          home-manager.nixosModules.home-manager
-        ];
-        specialArgs = {
-          inherit home-manager;
-        };
-      };
-      Rory-synapse = nixpkgs.lib.nixosSystem {
-        system = "x86_64-linux";
-        modules = [
-          ./host/Rory-synapse/configuration.nix
-          ./hardware-configuration.nix
-          home-manager.nixosModules.home-manager
-        ];
-        specialArgs = {
-          inherit home-manager;
-        };
-      };
-      Rory-discordbots = nixpkgs.lib.nixosSystem {
-        system = "x86_64-linux";
-        modules = [
-          ./host/Rory-discordbots/configuration.nix
-          ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
         ];
         specialArgs = {
           inherit botcore-v4;
           inherit home-manager;
+          inherit conduit;
         };
       };
       Rory-devenv = nixpkgs.lib.nixosSystem {
@@ -76,7 +49,6 @@
           inherit home-manager;
         };
       };
-      
     };
   };
 }