summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-08-28 21:40:53 +0200
committerRory& <root@rory.gay>2024-08-28 21:40:53 +0200
commit62fb7f7c127ca8aee56b3903ee207dec766d0a11 (patch)
treeac38a9bc6228b990687dcb636dc13080bfbd334f /flake.nix
parentDesktop/i686 changes (diff)
downloadRory-Open-Architecture-62fb7f7c127ca8aee56b3903ee207dec766d0a11.tar.xz
Monitoring?
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index d34ccc4..bcef2ce 100755
--- a/flake.nix
+++ b/flake.nix
@@ -17,9 +17,7 @@
     };
 
     # Draupnir module/package
-    nixpkgs-Draupnir = {
-      url = "github:TheArcaneBrony/nixpkgs/master";
-    };
+    nixpkgs-Draupnir.url = "github:TheArcaneBrony/nixpkgs/master";
 
     # Base modules
     home-manager.url = "github:nix-community/home-manager/master";
@@ -79,6 +77,17 @@
                     matrix-synapse-unwrapped = inputs.nixpkgs-master.legacyPackages.${pkgs.stdenv.hostPlatform.system}.matrix-synapse-unwrapped;
                     draupnir = inputs.nixpkgs-Draupnir.legacyPackages.${pkgs.stdenv.hostPlatform.system}.draupnir;
                   })
+
+                  #                  // matrix-nio
+                  (final: prev: {
+                    python312 = prev.python312.override {
+                      packageOverrides = python-self: python-super: {
+                        matrix-nio = python-super.matrix-nio.overridePythonAttrs (old: {
+                          pythonRelaxDeps = [ "aiohttp-socks" ];
+                        });
+                      };
+                    };
+                  })
                 ];
               }
             )