summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2023-10-04 23:14:58 +0200
committerRory& <root@rory.gay>2023-10-04 23:14:58 +0200
commit42bc49d716919c8311ac70a7808156494eb5de42 (patch)
tree216f722b63377097dcc6f3fd7557bfdc989064c4 /flake.nix
parentUpdate WSL (diff)
downloadRory-Open-Architecture-42bc49d716919c8311ac70a7808156494eb5de42.tar.xz
Improvements
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 833d949..07e9dce 100755
--- a/flake.nix
+++ b/flake.nix
@@ -32,6 +32,7 @@
 
   outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl }: {
     nixosConfigurations = {
+      #NIXPKGS FORK
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
@@ -45,6 +46,8 @@
           inherit conduit;
         };
       };
+
+      #UNSTABLE
       Rory-devenv = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
@@ -57,6 +60,19 @@
         };
       };
 
+      Rory-desktop = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          ./host/Rory-desktop/configuration.nix
+          ./hardware-configuration.nix
+          home-manager.nixosModules.home-manager
+          ({...}: { nix.registry.nixpkgs.flake = nixpkgs; })
+        ];
+        specialArgs = {
+          inherit home-manager;
+        };
+      };
+
       #STABLE
       RoryNix = nixpkgs-RoryNix.lib.nixosSystem {
         system = "i686-linux";