summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorEmma@Rory <root@rory.gay>2023-08-23 00:48:28 +0200
committerEmma@Rory <root@rory.gay>2023-08-23 00:48:28 +0200
commit29c9eeeb228dbe62160d176d9dc72521ec225332 (patch)
treeeab008e7b2a7beedded88dcd8eecb8722284c045 /flake.nix
parentConduit well-known (diff)
downloadRory-Open-Architecture-29c9eeeb228dbe62160d176d9dc72521ec225332.tar.xz
Add side laptop
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix23
1 files changed, 18 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index c797050..b8ef119 100755
--- a/flake.nix
+++ b/flake.nix
@@ -3,8 +3,15 @@
 
   inputs = {
     nixpkgs = {
-      #url = "github:NixOS/nixpkgs/nixos-unstable";
-      url="path:/Rory-Open-Architecture/nixpkgs";
+      url = "github:NixOS/nixpkgs/nixos-unstable";
+      #url="path:/Rory-Open-Architecture/nixpkgs";
+    };
+    nixpkgs-rory = {
+      #url = "path:/Rory-Open-Architecture/nixpkgs";
+      url = "github:TheArcaneBrony/nixpkgs/master";
+    };
+    nixpkgs-RoryNix = {
+      url = "github:NixOs/nixpkgs/nixos-22.11";
     };
     botcore-v4 = {
       url = "gitlab:BotCore-Devs/BotCore-v4/staging";
@@ -20,12 +27,11 @@
       # will probably also require you to always build from source.
       inputs.nixpkgs.follows = "nixpkgs";
     };
-
   };
 
-  outputs = { self, nixpkgs, home-manager, botcore-v4, conduit }: {
+  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit }: {
     nixosConfigurations = {
-      Rory-nginx = nixpkgs.lib.nixosSystem {
+      Rory-nginx = nixpkgs-rory.lib.nixosSystem {
         system = "x86_64-linux";
         modules = [
           ./host/Rory-nginx/configuration.nix
@@ -49,6 +55,13 @@
           inherit home-manager;
         };
       };
+      RoryNix = nixpkgs-RoryNix.lib.nixosSystem {
+        system = "i686-linux";
+        modules = [
+          ./host/RoryNix/configuration.nix
+          ./hardware-configuration.nix
+        ];
+      };
     };
   };
 }