1 files changed, 1 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 2c6fb9aacb..0ce8beb004 100755
--- a/setup.py
+++ b/setup.py
@@ -119,9 +119,7 @@ CONDITIONAL_REQUIREMENTS["mypy"] = [
# Tests assume that all optional dependencies are installed.
#
# parameterized_class decorator was introduced in parameterized 0.7.0
-#
-# We use `mock` library as that backports `AsyncMock` to Python 3.6
-CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0", "mock>=4.0.0"]
+CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0"]
CONDITIONAL_REQUIREMENTS["dev"] = (
CONDITIONAL_REQUIREMENTS["lint"]
@@ -152,12 +150,6 @@ setup(
long_description=long_description,
long_description_content_type="text/x-rst",
python_requires="~=3.6",
- entry_points={
- "console_scripts": [
- "synapse_homeserver = synapse.app.homeserver:main",
- "synapse_worker = synapse.app.generic_worker:main",
- ]
- },
classifiers=[
"Development Status :: 5 - Production/Stable",
"Topic :: Communications :: Chat",
|